Ultrasnow Will Be Updated To Unlock iOS 5.0.1, Still No Word On iPhone 4 BB 4.11.08

By -

Good news folks, the iPhone Dev team has confirmed that they are going to update their unlocking software Ultrasnow to work on iOS 5.0.1, but there is still no word on unlocking iPhone 4 baseband 4.11.08.

Ultrasnow real logo

The news comes directly from iPhone Dev team who released a new Redsnow update today, Redsnow 0.9.9b9b.

This new Ultrasnow which will be released on Monday will unlock the same baseband as previously. This Ultrasnow will NOT support new basebands, it is merely to support the new iOS 5.0.1

The basebands that are supported

  • 01.59.00
  • 04.26.08
  • 05.11.07
  • 05.12.01
  • 05.13.04
  • 06.15.00

Ultrasn0w compatability update (i.e. same baseband requirements) for 5.0.1 will be available on Cydia Monday

For those iPhone 4 users who are stuck on the baseband 4.11.08 this Ultrasnow update, Ultrasnow 1.2.5 will not unlock iPhone 4 on baseband 4.11.08.

Do not worry folks as not all hope is lost.

Even though Ultrasnow 1.2.5 will not unlock baseband 4.11.08 but it does not mean that the big update, Ultrasnow 1.3, would do the same. In fact when Ultrasnow 1.3 gets released, it will support new basebands and there is no doubt 4.11.08 will be on the list.

Secondly as most you are already aware about the untethered jailbreak for iOS 5 is being developed by the hacker pod2g. Untethered jailbreak does not only have an advantage for users who want to jailbreak but also for users who rely on carrier unlock.

We will update you more on this in the following days. So stay tuned.

Stay tuned at Maypalo and follow us on Twitter or join our Facebook Fanpage to keep yourself updated on all the latest News!

CEO & Founder of Maypalo

41 Comments to Ultrasnow Will Be Updated To Unlock iOS 5.0.1, Still No Word On iPhone 4 BB 4.11.08

  1. You “highly doubt” baseband 4.11.08 will be on the list for the major update of Ultrasn0w…was that a typo. It seems to contradict what was said just above it.

  2. I cant beleave that there is nutting that can help us unlock the bb04.11.08 yet. please, someone do something. now i wonder when will there be anything to really help us out.

  3. you guys dont think 4.11.8 willl be on the list?

    “In fact when Ultrasnow 1.3 gets released, it will support new basebands and we highly doubt 4.11.08 will be on the list.”

  4. Ultrasnow 1.3 will take a long time?

    Can I update my baseband with a the followings BB’s?

    •04.26.08
    •05.11.07
    •05.12.01
    •05.13.04
    •06.15.00

    I have the 4.11.08!!

  5. Would be awesome if 04.11.08 is included in next update. So many of us need it so bad. Keep up the good work.

  6. CESAR : You can’t, 4.11.08 is the latest for the iphone 4 (1.59.00 was the previous one).
    Those your mention are 3gs’ (Or other devices) basebands and therefore, not compatible with your iphone 4.
    You must wait. :/

  7. i think that the majority of the people are wishing for an bb 04.11.08 unlock solution more than for an Untethered Jailbreak,but sadly they are not finding any solution for the baseband. i prefer a tethered Jailbreak iphone with bb 04.11.08 working phone,but thats just me i guess

    • I agree with u 100%. wats the sence od having an untethered jailbreak iphone 4 and u rely on an carrier unlock. I have my iphone and i jailbroke it about 4 times and jus carry it back to normal. i cant use it to make a phone call and thats the thing is better then anything. We jus have to wait and pray.

  8. ok thanks for the post but is there any updates from gevey and/or miracle ?? why isn’t any formal words from this companies about if they looking for release a new turbo sim ??

  9. The word is no unlock for 04.11.08!

    Why?

    No reason given.

    If hey can’t or will not unlock these basebands WTF good are they?

    Millions of us are stuck with useless phones and they just keep handing out jailbreakes. WHO CARES!?! We need the unlock or the whole thing is GARBAGE!

    STOP DONATEING $$$ OR ANY SUPPORT FOR THESES SO CALLED “TEAMS”

    Let them get jobs like the rest of us, you are just buying them new gear every week and they are spongeing off the rest of us.

    STOP DONATEINE!!!!

  10. I don’t understand why ATT won’t release the unlock code for iphone customers and make it easier for everyone. I called today and they said they are unable to do that for the iphone but more then happy to do it with other phones.

  11. Please help, I am in France with two Iphones a 3gs and a 4, they are AtandT phones.

    The 4 is on ios 5 4.11.08. sounds like I need to wait,

    The 3gs I bought on Ebay in hopes I could use it in France on Orange until the 4 could be broke. The ebay seller had a cydia break and ultrasnow unlock on it. Unfortunately I cant use it, I get no service error, yet when I look in the about on the phone, it shows the orange network. The 3gs is running 4.3.3 and 5.16.05 am I screwed?

    I dont want to use the 6.15.00 Ipad firmware due to the complications with it.

    Any help or ideas out there, I am in France for 6 months with two really expensive ipods until the phones can be used!

    Thanks and happy holidays.

  12. Please we need to have the development Team working on unlocking baseband 4.11.08. Do we have an idea when they are going to release the new version?

  13. paul eveleigh

    Im still waiting for my iphone to be unlocked as well mistake and updated any now wont work but my service provider say they will unlock if they get permision from apple but its taking along time there is one site which is applexos.com which i have not used yet but would like to know if its any good any one used it ??????????? does not do software but it unlocks the phone via apple itself ……

  14. My ipod touch work great 😀 fu**ing 04.11.08 bb…. I dont need to jailbreak if I can’t call!!!!!!!!!!!!!!!!!!

  15. I bought a iphone 4 changed the whole thing to metallic blue and cant use it! Im about 2secs away from selling this shit. Its been like 6 months

Leave a Reply

Your email address will not be published. Required fields are marked *